Advisory Details

September 16th, 2015

Symantec Web Gateway Arbitrary PHP File Upload Remote Code Execution Vulnerability

ZDI-15-443
ZDI-CAN-2917

CVE ID ,
CVSS SCORE 8.5, (AV:N/AC:M/Au:S/C:C/I:C/A:C)
AFFECTED VENDORS Symantec
AFFECTED PRODUCTS Web Gateway
TIPPINGPOINT™ IPS CUSTOMER PROTECTION TippingPoint IPS customers are protected against this vulnerability by Digital Vaccine protection filter ID 19858. For further product information on the TippingPoint IPS: http://www.tippingpoint.com
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Symantec Web Gateway. Authentication is required to exploit this vulnerability, however it can be bypassed via reflected cross-site scripting.

The specific flaw exists within the admin_messages.php file which relies on mimetypes and file extensions to block potentially dangerous file uploads. An attacker can exploit this condition to upload arbitrary files as the apache user. Due to loose sudo restrictions, an attacker can add the setuid attribute and execute arbitrary code under the context of root.

VENDOR RESPONSE Symantec has issued an update to correct this vulnerability. More details can be found at:
http://www.symantec.com/security_response/securityupdates/detail.jsp?fid=security_advisory&pvid=security_advisory&year=&suid=20150916_00
DISCLOSURE TIMELINE
  • 2015-05-06 - Vulnerability reported to vendor
  • 2015-09-16 - Coordinated public release of advisory
CREDIT Jos Wetzels - LeakFree Security
BACK TO ADVISORIES