Advisory Details

May 24th, 2016

Apache ActiveMQ MOVE Method Remote Code Execution Vulnerability

ZDI-16-357
ZDI-CAN-3600

CVE ID CVE-2016-3088
CVSS SCORE 7.5, (AV:N/AC:L/Au:N/C:P/I:P/A:P)
AFFECTED VENDORS Apache
AFFECTED PRODUCTS ActiveMQ
VULNERABILITY DETAILS


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of Apache ActiveMQ. Authentication may or may not be required to exploit this vulnerability, according to how the product has been configured.

The specific flaw exists within the fileserver web service that is installed as part of this product. By issuing an HTTP PUT request and an HTTP MOVE request, an attacker can create an arbitrary file on the server with attacker controlled data. An attacker can further leverage this vulnerability to execute code on the server under the context of the ActiveMQ process.

VENDOR RESPONSE Apache has issued an update to correct this vulnerability. More details can be found at:
http://activemq.apache.org/security-advisories.data/CVE-2016-3088-announcement.txt
DISCLOSURE TIMELINE
  • 2016-03-29 - Vulnerability reported to vendor
  • 2016-05-24 - Coordinated public release of advisory
CREDIT rgod
BACK TO ADVISORIES