TippingPoint Zero Day Initiative
 

Trend Micro InterScan Web Security Virtual Appliance uihelper Privilege Escalation Vulnerability

ZDI-17-225: March 30th, 2017

CVSS Score

Affected Vendors

Affected Products

    InterScan Web Security Virtual Appliance

Vulnerability Details


This vulnerability allows attackers to escalate privileges on vulnerable installations of Trend Micro InterScan Web Security Virtual Appliance. Authentication is required to exploit this vulnerability.

The specific flaw exists within the uihelper application. The issue lies in the default configuration that allows the iscan user to execute commands under different privileges. An attacker can leverage this flaw in conjunction with other vulnerabilities to execute arbitrary code in the context of root.

Vendor Response

Trend Micro has issued an update to correct this vulnerability. More details can be found at:

Disclosure Timeline

    2017-01-05 - Vulnerability reported to vendor
    2017-03-30 - Coordinated public release of advisory

Credit

This vulnerability was discovered by:
    Steven Seeley of Source Incite