TippingPoint Zero Day Initiative
 

(Pwn2Own) Apple macOS speechsynthesisd Unsigned Dylib Loading Privilege Escalation Vulnerability

ZDI-17-347: May 15th, 2017

CVE ID

CVSS Score

Affected Vendors

Affected Products

    macOS

Vulnerability Details


This vulnerability allows local attackers to escalate privileges on vulnerable installations of Apple macOS. An attacker must first obtain the ability to execute low-privileged code on the target system in order to exploit this vulnerability.

The specific flaw exists within the speechsynthesisd service. The issue results from the lack of proper validation of a library prior to loading it. An attacker can leverage this vulnerability to escalate privileges under the context of the current service.

Vendor Response

Apple has issued an update to correct this vulnerability. More details can be found at:

Disclosure Timeline

    2017-03-15 - Vulnerability reported to vendor
    2017-05-15 - Coordinated public release of advisory

Credit

This vulnerability was discovered by:
    Niklas Baumstark and Samuel Groß