TippingPoint Zero Day Initiative
 

AlienVault Unified Security Management nfcapd Process_ipfix_template_withdraw Heap-based Buffer Overflow Remove Code Execution Vulnerability

ZDI-17-492: July 20th, 2017

CVSS Score

Affected Vendors

Affected Products

Vulnerability Details


This vulnerability allows remote attackers to execute arbitrary code on vulnerable installations of AlienVault Unified Security Management. Authentication is not required to exploit this vulnerability.

The specific flaw exists within nfcapd's Process_ipfix_template_withdraw function. The issue results from the lack of proper validation of the length of user-supplied data prior to copying it to a heap-based buffer. An attacker can leverage this vulnerability to execute arbitrary code under the context of root.

Vendor Response

AlienVault has issued an update to correct this vulnerability. More details can be found at:

Disclosure Timeline

    2017-01-10 - Vulnerability reported to vendor
    2017-07-20 - Coordinated public release of advisory

Credit

This vulnerability was discovered by:
    62600BCA031B9EB5CB4A74ADDDD6771E